Profile Picture

Problem Solved: Left bank blowing blue smoke

Posted By Tim Quinn 2 Months Ago
You don't have permission to rate!
Author
Message
Tim Quinn
Posted 2 Months Ago
View Quick Profile
Supercharged

Supercharged (223 reputation)Supercharged (223 reputation)Supercharged (223 reputation)Supercharged (223 reputation)Supercharged (223 reputation)Supercharged (223 reputation)Supercharged (223 reputation)Supercharged (223 reputation)Supercharged (223 reputation)

Group: Forum Members
Last Active: 2 days ago
Posts: 97, Visits: 1.1K
I want to thank all of you out there for helping me with the "ONLY LEFT BANK BLOWING BLUE SMOKE" problem.
Problem solved, it was because the rocker arms were pressurized and forced the head to flood with oil.
Removed screw and installed the oil return tubes and the flooding of the head went away.
TRIPLE BIG THANKS TO : Carl in Ohio who sent me the oil return tubes along with the brackets that hold the tubes in place. 3 X Thanks Carl.
Again, thanks to all of you.
Happy Tim in Florida.
carl
Posted 2 Months Ago
View Quick Profile
Supercharged

Supercharged (2.1K reputation)Supercharged (2.1K reputation)Supercharged (2.1K reputation)Supercharged (2.1K reputation)Supercharged (2.1K reputation)Supercharged (2.1K reputation)Supercharged (2.1K reputation)Supercharged (2.1K reputation)Supercharged (2.1K reputation)

Group: Forum Members
Last Active: Yesterday
Posts: 1.1K, Visits: 18.0K
Tim Quinn (2/11/2019)
I want to thank all of you out there for helping me with the "ONLY LEFT BANK BLOWING BLUE SMOKE" problem.
Problem solved, it was because the rocker arms were pressurized and forced the head to flood with oil.
Removed screw and installed the oil return tubes and the flooding of the head went away.
TRIPLE BIG THANKS TO : Carl in Ohio who sent me the oil return tubes along with the brackets that hold the tubes in place. 3 X Thanks Carl.
Again, thanks to all of you.
Happy Tim in Florida.
Thanks Tim,glad you got your problem solved  Carl



Reading This Topic


Site Meter